.rubocop.yml in image_voodoo-0.9.0 vs .rubocop.yml in image_voodoo-0.9.1
- old
+ new
@@ -36,16 +36,16 @@
# This is triggered for correct_orientation_impl. I could put these transforms
# in a table and then execute lambdas for each orientation but this is much
# more clear.
Metrics/CyclomaticComplexity:
- Max: 9
+ Max: 10
# A bunch of fields in a hash are basically generated data. Correcting them
# for column seems much too pedantic. I guess exclude is the right thing for
# an unusual file?
-Metrics/LineLength:
+Layout/LineLength:
Max: 132
Exclude:
- 'lib/image_voodoo/metadata.rb'
# Metadata classes have data in them. awt.rb is big and perhaps could be
@@ -85,18 +85,10 @@
# bin/image_voodoo main options block.
Metrics/BlockLength:
Exclude:
- 'bin/image_voodoo'
-# casecmp for this case seems like it is much less readable in a place where
-# performance could never matter (a 3-4 char downcase before processing an
-# image :) ). This could end up being important somewhere but as a default
-# on it feels weird since I find it less readable.
-Performance/Casecmp:
- Exclude:
- - 'lib/image_voodoo/awt.rb'
-
# Hash rocket looks much more natural in a rakefile for its deps.
Style/HashSyntax:
Exclude:
- 'Rakefile'
@@ -118,10 +110,10 @@
# than 3 chars. Silly rule even if I appreciate what it is trying to
# accomplish. Interestingly, in image_voodoo I do use h for height and
# w for width. Those probably could be written out but they are so common
# I am basically opting for short-hand. This is something I rarely do except
# domain-driven code like this (x,y,h,w).
-Naming/UncommunicativeMethodParamName:
+Naming/MethodParameterName:
Enabled: false
# This represents one of those frustrating dogmatic rules where if I followed
# this advice I would then violate the column length rule. I specifically
# use traditional if indented block in cases where if_mod doesn't fit.